如何配置适合WordPress建站的服务器

WordPress系统是由PHP开发的,相应的WordPress 对 PHP 版本和 MySQL 版本是有要求的,WordPress 对 PHP 和 MySQL 版本的要求主要分为核心 PHP 版本要求、主题 PHP 版本要求和插件 PHP 版本要求。

WordPress 核心的 PHP 和 MySQL 版本需求

根据 WordPress 的官方主机环境要求说明,WordPress 建议主机环境符合以下要求:

  • PHP 7.0或更高版本
  • MySQL 5. 6 或更高版本
  • HTTPS 支持

Apache 或者 Nginx 是运行 WordPress 最健壮和功能最丰富的服务器,一般建议服务器使用这两种中的其中一种。

WordPress 主题的 PHP 和 MySQL 版本需求

WordPress 主题的开发者成千上万,各个主题对 PHP 版本的需求也都不一样,WordPress 目前没有提供判断主题 PHP 版本需求的方法。

有些主题会把 PHP 版本需求写在 readme.txt 文件中,我们可以试着在主题文件包里面寻找这个文件查看下是否有PHP版本的描述。如果没有,可以联系主题开发者询问。

WordPress 插件 的 PHP 和 MySQL 版本要求

和主题不同,WordPress 已经在官方插件目录中直接列出了插件的 PHP 版本需求,我们可以直接在插件介绍页面右侧的插件元信息中查看,如下图:

有些插件为了防止 PHP 版本不能满足需求而带来的致命错误,会在插件激活时,判断服务器的 PHP 版本以确定是否激活插件功能。

关于主题和插件对 MySQL 版本的需求,目前并没有比较直接的判断方法,不过相对于 PHP,MySQL 版本之间的区别并不是太大,不至于版本不满足需求就直接出现致命错误而导致网站不能运行。

一般情况下WordPress主题队最新的PHP版本都会支持,如果实在不知道选择哪个版本的PHP,建议选择PHP7.2版本,MySQL选择5.6版本,基本上都能很好的支持我们搭建网站。

PHP7.0以上版本还带来了功能的增强和性能方面的较大提升,所以这里推荐你优先选择PHP7.0及以上版本。

优推网专注于WordPress外贸建站、WordPress企业建站和分享谷歌SEO排名技巧、Google优化心得、谷歌seo优化技巧和外贸采集站推广的知识,帮助企业通过谷歌SEO推广打开海外市场。
优推网 » 如何配置适合WordPress建站的服务器

发表评论